Running Scratch 3.0 requires a relatively new web browser:

Chrome 63 or higher, Edge 15 or higher, Firefox 57 or higher, Safari 11 or higher, Mobile Chrome 63 or higher, Mobile Safari 11 or higher. Internet Explorer is NOT supported.

Note:[1]

If your computer does not meet those requirements, it may work with an older version instead. For more information, see Compatibility of Versions of Scratch.

References

  1. https://scratch.mit.edu/info/faq/#about-scratch