Archive.png This article or section documents something not included in the current version of Scratch (3.0). It is only useful from a historical perspective.
This article or section documents an outdated version of Scratch (version 2.0). For this article in the current version, see Hidden Features (3.0). For this article in Scratch 1.4, see Hidden Features (1.4).

Scratch 2.0 had many hidden features dealing with clicking on a specific object or screen region while holding down the ⇧ Shift key, Ctrl key, or ⌘ Cmd key. Typically, these secrets were used to hide advanced features that would confuse a beginner who is new to Scratch.

Scratch Comments

Scratch Emojis

Meow.png

Scratch Emojis were a feature which allowed commenting emojis on a studio, project, or profile. Emojis could not be used in project descriptions. Each emoji had a keyword associated with it that needed to be included for the emoji to appear.

File Menu (2.0)

The offline and online editor had slightly different hidden options when shift-clicking the "File" menu. In the online editor, the option Save Project Summary appeared. However, when shift-clicking in the offline editor, another option appeared: "Import Experimental Extension".

Edit Menu (2.0)

Archive.png This article or section documents something not included in the current version of Scratch (3.0). It is only useful from a historical perspective.
The shift-click accessible Edit menu options.
The 'Edit Block Colors' menu

In the online editor, shift-clicking the Edit menu at the top of the program opened many options, including the Motor Blocks. The following contains all the options, including the normal ones:

Turbo Mode

Shift-clicking the green flag ran the project in turbo mode, which ran the project extremely fast, having minimal to no wait between blocks. This was useful for solving large mathematical operations or running a 3D engine smoothly.

Muting (2.0)

Holding the ctrl key ( key on macOS) and clicking the green flag ran the project with no sound. This was useful for quickly muting a project.

Lists

Pressing ⇧ Shift+↵ Enter while editing a list item would create a new item before it. Pressing the Tab ⇆ key while editing a list item would move the cursor to the next item, and pressing Tab ⇆+⇧ Shift while would move the cursor to the previous item.

Block Arguments

Pressing the Tab ⇆ key while editing an argument would move the cursor to the next editable argument in a block, and pressing Tab ⇆+⇧ Shift while editing an argument would move the cursor to the previous editable argument.

Tool Buttons (2.0)

Deleting a sprite with the "scissors" tool.

The top bar of the Scratch program contained stamper, scissors, outward arrows, inward arrows, and question mark buttons. After being selected, they could be used to duplicate and delete sprites, blocks, comments, costumes, and sounds, grow and shrink sprites and costumes, or get help for a block or specific part of the program. However, after performing that operation, typically the tool must be selected to perform the task again. As an alternative to the repetitively selecting the tool, one could hold down the ⇧ Shift key to use the tool multiple times without it exiting and requiring selection again.

Costumes/Sprites

When importing a new sprite, the ⇧ Shift key could be held down to import multiple sprites. Clicking on a selected sprite would deselect it, and vice versa. The same was true when importing costumes.

Paint Editor

The paint editor itself had multiple features using the ⇧ Shift key.

Duplicate Tool

When using the "duplicate tool" (stamper) in the vector editor, holding down the ⇧ Shift key while stamping allowed one to continuously stamp the same object without the need to re-select it.

Spline Manipulation

The Scratch 2.0 vector editor used splines (control points) to store information on an image instead of a bitmap's array of pixels. When modifying these splines with the reshape tool, one could shift-click on a spline to disconnect that point from the object (split it at the location). Additionally, shift-clicking between two splines created a new spline which had a smooth bend and curvature relative to the two adjacent splines.

Perfect Shapes

When drawing a rectangle, holding down the shift key made it a square, with each side the same length. When drawing an oval, holding down the shift key made it a perfect circle. This feature was useful for drawing exact, unifying shapes, and for demonstrative purposes in a mathematical tutorial project. Holding the shift key when drawing lines would also make them perfectly horizontal or vertical.

Perfect Rotation

After selecting a shape (in vector) or an area of pixels (in bitmap), holding shift while rotating the shape would force the rotation to snap to angles that are multiples of 45 degrees. This was useful for rotating shapes at exactly those angle increments instead of having to manually line up the cursor to rotate to such angles.

Sound Editor

The sound editor had two features using the ⇧ Shift key.

Cropping Sounds

Cropping sounds could be accomplished more easily by highlighting the area you want to keep and deleting the rest of the file. When a sound section is highlighted, one could hit ⇧ Shift+delete or ⇧ Shift+← Backspace to keep the highlighted section and remove the rest of the sound, cropping it to the desired section.

Applying Effects (2.0)

Shift-clicking the effects menu and selecting "louder" or "softer" would change the volume at a smaller interval than by doing so without holding shift.

Scrolling

In the scripts area and other places with a scroll bar, holding down the ⇧ Shift key and scrolling down on the scroll wheel would scroll right, and holding down the shift key and scrolling up on the scroll wheel would scroll left.

Rendering

Pressing ctrl+m (⌘ Cmd+m on macOS) would make Scratch toggle between using the Pixel Bender and Stage3D rendering engines. This was likely intended by the Scratch Team to be used for testing.[citation needed]

See Also

Cookies help us deliver our services. By using our services, you agree to our use of cookies.