This article or section documents the current version of Scratch (version 3.0). For this article in Scratch 2.0, see Header (editor) (2.0).
The editor header as seen from the top of the Scratch 3.0 interface.

The Editor Header is a narrow strip of blue at the top of the Scratch Interface containing some context menus, tools, links, and options. It is always present and cannot be collapsed unlike ribbons in some other computer programs such as Microsoft Office.

Accessing the Editor Header

To access the editor header, the Scratch program must first be opened. Once complete, the editor header automatically appears at the top of the interface. Its features can be accessed by using the mouse pointer to click on the desired function. The ribbon is divided into three subsections containing similar options.

Options for all Users

Scratch Homepage Link

This button is a link to the Scratch home page.

The top-left of the editor header contains the Scratch Logo. Clicking the button will direct the web browser to the Scratch home page. It does not open the home page in a new tab but will replace the project editor. It cannot be right-clicked either to open the home page in a different tab when in the project editor.

Language Menu

The globe button drops-down a list of other languages.

Scratch is available in dozens of languages. The "globe" image in the editor header contains a drop-down menu of all the available languages the Scratch program can be changed to. The languages are written in their own tongue; for example, Spanish is written as "Español" so native Spanish speakers understand it is their language.

File Menu

Main article: File Menu

The file menu contains options for the following: creating a new blank Scratch project, saving the current project either to the Scratch servers or one's local computer, and uploading a project from the computer.

Edit Menu

Main article: Edit Menu

The edit menu contains options for the following: Restoring the last deleted item and turning on Turbo Mode.

Tutorials

The "Tutorials" text with a lightbulb is a button that opens the Tutorial Library to select a Project Tutorial. This window can provide useful insight for anybody struggling to develop a project. It is especially useful for New Scratchers who have little experience.

Options for a Logged-In User

Note Note: Users can only rename, share, save, and make edits to their own projects.

Project Name

The project name will appear on the editor header. Click it to change the name of the project, which automatically updates the name being shown on the browser tab.

Share

The orange Share button shares the project to the Scratch Website.

See Project Page

This button, along with a switch icon, switches the editor to the project page, after saving.

Save Status

Manually saving a Scratch project.

Near the top-right is the last subsection of the editor header which begins with the save status. If the project's current state is that which is saved, it will not show. If a block is moved, or anything is adjusted, it will adjust to the text "Save Now" which can be clicked to manually save the project. Scratch does automatically save the project frequently, but this is the easiest method of manually saving it. Alternatively, the project can be saved from the File menu.

My Stuff

Main article: My Stuff

The envelope button directs the web browser to My Stuff when clicked with the mouse pointer. When hovered over with the mouse, its color becomes darker to indicate it can be clicked. "My Stuff" is a feature of the website that contains all the Scratch projects, both shared and unshared, of the logged-in user. The page will not open in a new tab but will replace the project editor.

Username and Associated Options

When logged in, one's username will be the right-most option of the editor header. Clicking this will display a drop-down menu with the following options: "Profile", "My Stuff", "Account Settings", and "Log Out". There is a darker grey line between the last two options to isolate "Log Out". If signed out, the web browser will be directed to the Scratch home page.

Options for a Logged-Out User

Join Scratch

Options available only to someone who is not logged into a Scratch account.

Scratch projects cannot be saved in the online editor to the Scratch servers unless one has a Scratch account. One has the ability to create a Scratch account without closing their current work by clicking "Join Scratch" on the editor header. When selected, the editor will be darkened out and a small menu will appear in the center of the screen with steps to creating a Scratch account. Once made, the project can then be saved to the Scratch servers so the work is not lost.

Note Note: Alternatively, the project can be downloaded to one's personal computer from the File Menu to save a project.

Sign In

If one is logged out and is working on a project in the editor, they can sign in directly from the editor without ever closing the project. This can be accomplished with the "Sign in" button, which is right-most on the editor header. When selected, a small menu will appear in the corner of the screen where credentials can be entered. Once logged in, the project can be saved to the Scratch servers.

Cookies help us deliver our services. By using our services, you agree to our use of cookies.